{"action":"Upgrade smarty4 to 4.1.1-1 or later.","affected":[{"fixed":"4.1.1-1","introduced":"0"}],"component":"smarty4","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.1.1-1"],"id":"tcs_01M5NFJ7RAP9X3Y8TH8K2NMY63","modified_at":"2026-10-23T18:03:08.902736849Z","published_at":"2022-01-10T20:15:08Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-29454","https://security-tracker.debian.org/tracker/CVE-2021-29454"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-29454#Debian:12/smarty4","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-29454"}],"summary":"Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by"}