{"action":"Upgrade nim to 1.4.2-1 or later.","affected":[{"fixed":"1.4.2-1","introduced":"0"}],"component":"nim","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.4.2-1"],"id":"tcs_01M5NFJCQ6MEXNX1AYYDTJJ680","modified_at":"2026-10-23T18:03:12.552604518Z","published_at":"2021-05-07T16:15:08.347Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-29495","https://security-tracker.debian.org/tracker/CVE-2021-29495"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-29495","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-29495"}],"summary":"Nim is a statically typed compiled systems programming language. In Nim standard library before 1.4.2, httpClient SSL/TLS certificate verification was disabled by default. Users can upgrade to version"}