{"action":"Upgrade phpseclib to 1.0.19-3 or later.","affected":[{"fixed":"1.0.19-3","introduced":"0"}],"component":"phpseclib","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.0.19-3"],"id":"tcs_01M5NFJYH73T04584SVA5TP4V2","modified_at":"2026-10-23T18:04:00.048934949Z","published_at":"2021-04-06T15:15:13.497Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-30130","https://security-tracker.debian.org/tracker/CVE-2021-30130"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-30130#Debian:12/phpseclib","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-30130"}],"summary":"phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification."}