{"action":"Upgrade gnuchess to 6.2.9-0.1 or later.","affected":[{"fixed":"6.2.9-0.1","introduced":"0"}],"component":"gnuchess","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["6.2.9-0.1"],"id":"tcs_01M5NFK2PN331X2G6YD6H1EZDG","modified_at":"2026-10-23T18:02:52.257676311Z","published_at":"2021-04-07T12:15:16.437Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-30184","https://security-tracker.debian.org/tracker/CVE-2021-30184"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-30184#Debian:13/gnuchess","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-30184"}],"summary":"GNU Chess 6.2.7 allows attackers to execute arbitrary code via crafted PGN (Portable Game Notation) data. This is related to a buffer overflow in the use of a .tmp.epd temporary file in the cmd_pgnloa"}