{"action":"Upgrade vim to 9.2.0078-r0 or later.","affected":[{"fixed":"9.2.0078-r0","introduced":"0"}],"component":"vim","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["9.2.0078-r0"],"id":"tcs_01M5NFMTGMDDC2YHPNYKFN5QY6","modified_at":"2026-10-01T02:17:49.228287555Z","published_at":"2026-02-27T22:16:25.493Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-28421","https://security.alpinelinux.org/vuln/CVE-2026-28421"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-28421","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-28421"}],"summary":"Vim is an open source, command line text editor. Versions prior to 9.2.0077 have a heap-buffer-overflow and a segmentation fault (SEGV) exist in Vim's swap file recovery logic. Both are caused by unva"}