{"action":"Upgrade rust-pleaser to 0.4.1-1 or later.","affected":[{"fixed":"0.4.1-1","introduced":"0"}],"component":"rust-pleaser","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.4.1-1"],"id":"tcs_01M5NFNBT455WAJ3CWTBKQR4EX","modified_at":"2026-10-23T18:04:49.829387187Z","published_at":"2021-05-27T13:15:08.140Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-31154","https://security-tracker.debian.org/tracker/CVE-2021-31154"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-31154","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-31154"}],"summary":"pleaseedit in please before 0.4 uses predictable temporary filenames in /tmp and the target directory. This allows a local attacker to gain full root privileges by staging a symlink attack."}