{"action":"Upgrade rust-pleaser to 0.4.1-1 or later.","affected":[{"fixed":"0.4.1-1","introduced":"0"}],"component":"rust-pleaser","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.4.1-1"],"id":"tcs_01M5NFNCAH1GJQ28TJSGFTWJ8D","modified_at":"2026-10-23T18:03:13.411716939Z","published_at":"2021-05-27T13:15:08.173Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-31155","https://security-tracker.debian.org/tracker/CVE-2021-31155"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-31155#Debian:14/rust-pleaser","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-31155"}],"summary":"Failure to normalize the umask in please before 0.4 allows a local attacker to gain full root privileges if they are allowed to execute at least one command."}