{"action":"Upgrade sudo to 1.9.5p1-1.1 or later.","affected":[{"fixed":"1.9.5p1-1.1","introduced":"0"}],"component":"sudo","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.9.5p1-1.1"],"id":"tcs_01M5NFNQ9CRASCPAG7Z55ST6M8","modified_at":"2026-10-23T18:03:14.076812847Z","published_at":"2021-01-26T21:15:12.987Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-3156","https://security-tracker.debian.org/tracker/CVE-2021-3156"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-3156#Debian:14/sudo","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-3156"}],"summary":"Sudo before 1.9.5p2 contains an off-by-one error that can result in a heap-based buffer overflow, which allows privilege escalation to root via \"sudoedit -s\" and a command-line argument that ends with"}