{"action":"Upgrade python2.7 to 2.7.18-2 or later.","affected":[{"fixed":"2.7.18-2","introduced":"0"}],"component":"python2.7","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.18-2"],"id":"tcs_01M5NFNSHMY1QZWK3FVCBP20Z0","modified_at":"2026-08-27T23:04:02.364649351Z","published_at":"2021-01-19T06:15:12.967Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-3177","https://security-tracker.debian.org/tracker/CVE-2021-3177"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-3177","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-3177"}],"summary":"Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctypes/callproc.c, which may lead to remote code execution in certain Python applications that accept floating-point numbers as untrus"}