{"action":"Upgrade squid to 4.13-10 or later.","affected":[{"fixed":"4.13-10","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.13-10"],"id":"tcs_01M5NFNTX06FWY3Q4VZBPP8C63","modified_at":"2026-10-23T18:03:13.575050266Z","published_at":"2021-05-27T13:15:08.270Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-31806","https://security-tracker.debian.org/tracker/CVE-2021-31806"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-31806#Debian:13/squid","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-31806"}],"summary":"An issue was discovered in Squid before 4.15 and 5.x before 5.0.6. Due to a memory-management bug, it is vulnerable to a Denial of Service attack (against all clients using the proxy) via HTTP Range r"}