{"action":"Upgrade redmine to 5.0.0-1 or later.","affected":[{"fixed":"5.0.0-1","introduced":"0"}],"component":"redmine","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.0.0-1"],"id":"tcs_01M5NFNZEFS0RPS4JJRMX3ZJ0Y","modified_at":"2026-10-23T18:03:14.099264520Z","published_at":"2021-04-28T07:15:07.583Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-31863","https://security-tracker.debian.org/tracker/CVE-2021-31863"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-31863#Debian:14/redmine","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-31863"}],"summary":"Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the"}