{"action":"Upgrade klibc to 2.0.8-6 or later.","affected":[{"fixed":"2.0.8-6","introduced":"0"}],"component":"klibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.0.8-6"],"id":"tcs_01M5NFP15BD3C0X6DP0EDWQ1FZ","modified_at":"2026-10-23T18:03:14.697009524Z","published_at":"2021-04-30T06:15:07.313Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-31872","https://security-tracker.debian.org/tracker/CVE-2021-31872"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-31872#Debian:13/klibc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-31872"}],"summary":"An issue was discovered in klibc before 2.0.9. Multiple possible integer overflows in the cpio command on 32-bit systems may result in a buffer overflow or other security impact."}