{"action":"Upgrade openvpn to 2.6.20-r0 or later.","affected":[{"fixed":"2.6.20-r0","introduced":"2.6.0"}],"component":"openvpn","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["2.6.20-r0"],"id":"tcs_01M5NFPHZ21B7VH2N3YFSQAXY7","modified_at":"2026-10-01T02:17:49.266292370Z","published_at":"2026-06-08T20:17:00.497Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-35058","https://security.alpinelinux.org/vuln/CVE-2026-35058"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-35058#Alpine:v3.23/openvpn","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-35058"}],"summary":"Improper validation of packet length during tls-crypt-v2 key extraction in OpenVPN 2.6.0 through 2.6.19 and 2.7_alpha1 through 2.7.1 allows authenticated attackers to trigger a fatal assertion and cau"}