{"action":"Upgrade perl to 5.42.2-r0 or later.","affected":[{"fixed":"5.42.2-r0","introduced":"5.9.4"}],"component":"perl","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["5.42.2-r0"],"id":"tcs_01M5NFQMN0H9B7CHPDKWD92BKT","modified_at":"2026-10-01T02:17:49.285466608Z","published_at":"2026-03-29T21:16:15.717Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-4176","https://security.alpinelinux.org/vuln/CVE-2026-4176"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-4176","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-4176"}],"summary":"Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib."}