{"action":"Upgrade node-got to 11.8.1+~cs53.13.17-3 or later.","affected":[{"fixed":"11.8.1+~cs53.13.17-3","introduced":"0"}],"component":"node-got","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["11.8.1+~cs53.13.17-3"],"id":"tcs_01M5NFQQGFJF0W58F5MG9QZRH3","modified_at":"2026-10-23T18:03:29.560824888Z","published_at":"2021-05-24T16:15:08.133Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-33502","https://security-tracker.debian.org/tracker/CVE-2021-33502"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-33502#Debian:14/node-got","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-33502"}],"summary":"The normalize-url package before 4.5.1, 5.x before 5.3.1, and 6.x before 6.0.1 for Node.js has a ReDoS (regular expression denial of service) issue because it has exponential performance for data: URL"}