{"action":"Upgrade libsolv to 0.7.17-1 or later.","affected":[{"fixed":"0.7.17-1","introduced":"0"}],"component":"libsolv","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.7.17-1"],"id":"tcs_01M5NFR441SFBZD54ZHJBJAMHD","modified_at":"2026-10-23T18:02:30.316126559Z","published_at":"2021-09-02T15:15:07.803Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-33938","https://security-tracker.debian.org/tracker/CVE-2021-33938"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-33938#Debian:14/libsolv","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-33938"}],"summary":"Buffer overflow vulnerability in function prune_to_recommended in src/policy.c in libsolv before 0.7.17 allows attackers to cause a Denial of Service."}