{"action":"Upgrade rsync to 3.4.3-r0 or later.","affected":[{"fixed":"3.4.3-r0","introduced":"0"}],"component":"rsync","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["3.4.3-r0"],"id":"tcs_01M5NFRTDTC1WZN02A5KJC6FFC","modified_at":"2026-10-01T02:17:49.302738388Z","published_at":"2026-05-20T02:16:36.727Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-43620","https://security.alpinelinux.org/vuln/CVE-2026-43620"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-43620#Alpine:v3.24/rsync","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-43620"}],"summary":"Rsync version 3.4.2 and prior contain a receiver-side out-of-bounds array read vulnerability in recv_files() in receiver.c that allows a malicious rsync server to crash the rsync client process. Attac"}