{"action":"Upgrade linux to 5.10.38-1 or later.","affected":[{"fixed":"5.10.38-1","introduced":"0"}],"component":"linux","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.10.38-1"],"id":"tcs_01M5NFRXRAZ8R440V5KJBEYDEC","modified_at":"2026-10-23T18:04:00.163722039Z","published_at":"2021-05-06T13:15:12.840Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-3501","https://security-tracker.debian.org/tracker/CVE-2021-3501"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-3501#Debian:14/linux","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-3501"}],"summary":"A flaw was found in the Linux kernel in versions before 5.12. The value of internal.ndata, in the KVM API, is mapped to an array index, which can be updated by a user process at anytime which could le"}