{"action":"Upgrade hivex to 1.3.20-1 or later.","affected":[{"fixed":"1.3.20-1","introduced":"0"}],"component":"hivex","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.3.20-1"],"id":"tcs_01M5NFRYRE0RY60F0PSZ4DPMXJ","modified_at":"2026-10-23T18:03:15.641153043Z","published_at":"2021-05-11T23:15:09.050Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-3504","https://security-tracker.debian.org/tracker/CVE-2021-3504"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-3504#Debian:14/hivex","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-3504"}],"summary":"A flaw was found in the hivex library in versions before 1.3.20. It is caused due to a lack of bounds check within the hivex_open function. An attacker could input a specially crafted Windows Registry"}