{"action":"Upgrade node-glob-parent to 6.0.2+~5.1.1-1 or later.","affected":[{"fixed":"6.0.2+~5.1.1-1","introduced":"0"}],"component":"node-glob-parent","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["6.0.2+~5.1.1-1"],"id":"tcs_01M5NFS02NWN8BH69FQ3EX08BW","modified_at":"2026-10-23T18:04:00.642397246Z","published_at":"2022-12-26T07:15:11.730Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-35065","https://security-tracker.debian.org/tracker/CVE-2021-35065"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-35065#Debian:13/node-glob-parent","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-35065"}],"summary":"The glob-parent package before 6.0.1 for Node.js allows ReDoS (regular expression denial of service) attacks against the enclosure regular expression."}