{"action":"Upgrade varnish to 6.5.2-1 or later.","affected":[{"fixed":"6.5.2-1","introduced":"0"}],"component":"varnish","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["6.5.2-1"],"id":"tcs_01M5NFTRMXCY8P6SAPHF4YNMH4","modified_at":"2026-10-23T18:03:29.682095772Z","published_at":"2021-07-14T17:15:08.253Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-36740","https://security-tracker.debian.org/tracker/CVE-2021-36740"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-36740","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-36740"}],"summary":"Varnish Cache, with HTTP/2 enabled, allows request smuggling and VCL authorization bypass via a large Content-Length header for a POST request. This affects Varnish Enterprise 6.0.x before 6.0.8r3, an"}