{"action":"Upgrade php-dompdf to 2.0.2+dfsg-1 or later.","affected":[{"fixed":"2.0.2+dfsg-1","introduced":"0"}],"component":"php-dompdf","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.0.2+dfsg-1"],"id":"tcs_01M5NFWWRRCZVSJN70ZHYPG3EF","modified_at":"2026-10-23T18:03:31.489186727Z","published_at":"2024-11-15T11:15:05.763Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-3838","https://security-tracker.debian.org/tracker/CVE-2021-3838"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-3838","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-3838"}],"summary":"DomPDF before version 2.0.0 is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the file_get_contents() function. An attacker who can upload files of"}