{"action":"Upgrade cyclonedds to 0.8.1-2 or later.","affected":[{"fixed":"0.8.1-2","introduced":"0"}],"component":"cyclonedds","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.8.1-2"],"id":"tcs_01M5NFWYFBVH8KFMKEEET0P6Z8","modified_at":"2026-10-23T18:03:32.370685452Z","published_at":"2022-05-05T17:15:09.537Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-38441","https://security-tracker.debian.org/tracker/CVE-2021-38441"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-38441#Debian:13/cyclonedds","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-38441"}],"summary":"Eclipse CycloneDDS versions prior to 0.8.0 are vulnerable to a write-what-where condition, which may allow an attacker to write arbitrary values in the XML parser."}