{"action":"Upgrade haproxy to 2.2.16-1 or later.","affected":[{"fixed":"2.2.16-1","introduced":"0"}],"component":"haproxy","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.2.16-1"],"id":"tcs_01M5NFXPB8K8P7RPBM8X09PV99","modified_at":"2026-10-23T18:03:38.258707495Z","published_at":"2021-08-17T19:15:08.287Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-39241","https://security-tracker.debian.org/tracker/CVE-2021-39241"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-39241#Debian:14/haproxy","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-39241"}],"summary":"An issue was discovered in HAProxy 2.0 before 2.0.24, 2.2 before 2.2.16, 2.3 before 2.3.13, and 2.4 before 2.4.3. An HTTP method name may contain a space followed by the name of a protected resource."}