{"action":"Upgrade ruby-apollo-upload-server to 2.1.0-1 or later.","affected":[{"fixed":"2.1.0-1","introduced":"0"}],"component":"ruby-apollo-upload-server","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.1.0-1"],"id":"tcs_01M5NFYFSFQQVQJ6QX9MP8H7YK","modified_at":"2026-10-23T18:03:33.231435835Z","published_at":"2021-10-05T15:15:07.727Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-39880","https://security-tracker.debian.org/tracker/CVE-2021-39880"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-39880","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-39880"}],"summary":"A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions st"}