{"action":"Upgrade weechat to 3.2.1-1 or later.","affected":[{"fixed":"3.2.1-1","introduced":"0"}],"component":"weechat","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.2.1-1"],"id":"tcs_01M5NFZ32293AT380Y164B98PY","modified_at":"2026-10-23T18:04:50.813159968Z","published_at":"2021-09-05T18:15:07.260Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-40516","https://security-tracker.debian.org/tracker/CVE-2021-40516"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-40516#Debian:14/weechat","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-40516"}],"summary":"WeeChat before 3.2.1 allows remote attackers to cause a denial of service (crash) via a crafted WebSocket frame that trigger an out-of-bounds read in plugins/relay/relay-websocket.c in the Relay plugi"}