{"action":"Upgrade expat to 2.8.4-r0 or later.","affected":[{"fixed":"2.8.4-r0","introduced":"0"}],"component":"expat","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["2.8.4-r0"],"id":"tcs_01M5NFZXXXWXSN715E4QJ56ES0","modified_at":"2026-10-01T02:17:49.406953835Z","published_at":"2026-08-20T05:16:29.610Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-76956","https://security.alpinelinux.org/vuln/CVE-2026-76956"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-76956#Alpine:v3.22/expat","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-76956"}],"summary":"In libexpat 2.8.2 and 2.8.3 before 2.8.4, misinterpretation of getentropy's return code leads to insufficient entropy, which results in being vulnerable to hash flooding attacks, causing a denial of s"}