{"action":"Upgrade expat to 2.8.4-r0 or later.","affected":[{"fixed":"2.8.4-r0","introduced":"0"}],"component":"expat","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["2.8.4-r0"],"id":"tcs_01M5NFZYM063CHYYPV44Q0V2DY","modified_at":"2026-10-01T02:17:49.408047405Z","published_at":"2026-08-20T05:16:29.747Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-76957","https://security.alpinelinux.org/vuln/CVE-2026-76957"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-76957#Alpine:v3.22/expat","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-76957"}],"summary":"libexpat before 2.8.4 lacks handler call depth tracking with custom encoding callbacks. Thus, a use-after-free can occur. NOTE: this is similar to CVE-2026-50219, CVE-2026-56131 and CVE-2026-56412."}