{"action":"Upgrade squirrel3 to 3.1-8.2+deb13u1 or later.","affected":[{"fixed":"3.1-8.2+deb13u1","introduced":"0"}],"component":"squirrel3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.1-8.2+deb13u1"],"id":"tcs_01M5NG08G97Y2127KYK0NWCMV3","modified_at":"2026-10-28T17:00:05.167213405Z","published_at":"2022-07-28T21:15:08.057Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-41556","https://security-tracker.debian.org/tracker/CVE-2021-41556"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-41556","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-41556"}],"summary":"sqclass.cpp in Squirrel through 2.2.5 and 3.x through 3.1 allows an out-of-bounds read (in the core interpreter) that can lead to Code Execution. If a victim executes an attacker-controlled squirrel s"}