{"action":"Upgrade squid to 5.2-1 or later.","affected":[{"fixed":"5.2-1","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.2-1"],"id":"tcs_01M5NG0ACMT06M10NKQ0HRFXVB","modified_at":"2026-10-23T18:04:15.772827049Z","published_at":"2021-10-18T09:15:08.823Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-41611","https://security-tracker.debian.org/tracker/CVE-2021-41611"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-41611#Debian:14/squid","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-41611"}],"summary":"An issue was discovered in Squid 5.0.6 through 5.1.x before 5.2. When validating an origin server or peer certificate, Squid may incorrectly classify certain certificates as trusted. This problem allo"}