{"action":"Upgrade ruby2.7 to 2.7.4-1+deb11u1 or later.","affected":[{"fixed":"2.7.4-1+deb11u1","introduced":"0"}],"component":"ruby2.7","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.4-1+deb11u1"],"id":"tcs_01M5NG0EZQ0XYPZP9Y89P9DJWV","modified_at":"2026-08-27T23:04:10.427043671Z","published_at":"2022-01-01T06:15:07.293Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-41819","https://security-tracker.debian.org/tracker/CVE-2021-41819"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-41819","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-41819"}],"summary":"CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem through 0.3.0 for Ruby."}