{"action":"Upgrade pcre2 to 10.48-r0 or later.","affected":[{"fixed":"10.48-r0","introduced":"0"}],"component":"pcre2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["10.48-r0"],"id":"tcs_01M5NG0QPXHBCW2Z7P2HX94ZF4","modified_at":"2026-10-21T05:30:02.501998203Z","published_at":"2026-09-11T04:18:03.970Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-89158","https://security.alpinelinux.org/vuln/CVE-2026-89158"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-89158#Alpine:v3.24/pcre2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-89158"}],"summary":"PCRE2 before 10.48, on 32-bit platforms, has a pcre2_compile_32 integer overflow and resultant out-of-bounds write."}