{"action":"Upgrade libxi to 1.8.4-r0 or later.","affected":[{"fixed":"1.8.4-r0","introduced":"0"}],"component":"libxi","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["1.8.4-r0"],"id":"tcs_01M5NG10TTXN2EX6W1ASWTPXQZ","modified_at":"2026-10-18T10:30:02.697771213Z","published_at":"2026-09-24T17:17:10.183Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-93542","https://security.alpinelinux.org/vuln/CVE-2026-93542"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-93542","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-93542"}],"summary":"An out-of-bounds read in libXi's XI2 class parsing via size_classes() and copy_classes() in libXi before 1.8.4 could be used by malicous servers to crash the X client."}