{"action":"Upgrade expat to 2.8.5-r0 or later.","affected":[{"fixed":"2.8.5-r0","introduced":"0"}],"component":"expat","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["2.8.5-r0"],"id":"tcs_01M5NG12N5D188VM6WPE1M2TDA","modified_at":"2026-10-18T10:30:02.727361388Z","published_at":"2026-09-19T23:17:10.203Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-93990","https://security.alpinelinux.org/vuln/CVE-2026-93990"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-93990","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-93990"}],"summary":"Expat before 2.8.5 fails to validate that a high surrogate in UTF-16 input is followed by a low surrogate, allowing malformed UTF-16 sequences to be accepted. Attackers can supply UTF-16 encoded XML c"}