{"action":"Upgrade libx11 to 1.8.14-r0 or later.","affected":[{"fixed":"1.8.14-r0","introduced":"0"}],"component":"libx11","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["1.8.14-r0"],"id":"tcs_01M5NG148ZGH7D1RPCWVE91Z8V","modified_at":"2026-10-18T10:30:02.704175959Z","published_at":"2026-09-28T09:17:08.247Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-94284","https://security.alpinelinux.org/vuln/CVE-2026-94284"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-94284","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-94284"}],"summary":"An out-of-bounds read vulnerability in libX11's XIM trigger-key registration parser in libX11 before 1.8.14 could be used by malicious X servers to crash attached X clients."}