{"action":"Upgrade opensc to 0.22.0-1 or later.","affected":[{"fixed":"0.22.0-1","introduced":"0"}],"component":"opensc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.22.0-1"],"id":"tcs_01M5NG166NEREPW1ARVQ4TP55A","modified_at":"2026-10-23T18:04:16.164870807Z","published_at":"2022-04-18T17:15:16.303Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-42781","https://security-tracker.debian.org/tracker/CVE-2021-42781"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-42781","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-42781"}],"summary":"Heap buffer overflow issues were found in Opensc before version 0.22.0 in pkcs15-oberthur.c that could potentially crash programs using the library."}