{"action":"Upgrade ruby-devise-two-factor to 4.0.2-1 or later.","affected":[{"fixed":"4.0.2-1","introduced":"0"}],"component":"ruby-devise-two-factor","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.0.2-1"],"id":"tcs_01M5NG1ASR2JB6QWE19V8E7K3S","modified_at":"2026-10-23T18:04:38.775369874Z","published_at":"2022-04-11T20:15:16.037Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-43177","https://security-tracker.debian.org/tracker/CVE-2021-43177"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-43177","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-43177"}],"summary":"As a result of an incomplete fix for CVE-2015-7225, in versions of devise-two-factor prior to 4.0.2 it is possible to reuse a One-Time-Password (OTP) for one (and only one) immediately trailing interv"}