{"action":"Upgrade teeworlds to 0.7.5-2 or later.","affected":[{"fixed":"0.7.5-2","introduced":"0"}],"component":"teeworlds","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.7.5-2"],"id":"tcs_01M5NG1FHZ8Y8S9WPDG5QDPVCS","modified_at":"2026-10-23T18:04:16.442305301Z","published_at":"2021-12-15T15:15:10.857Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-43518","https://security-tracker.debian.org/tracker/CVE-2021-43518"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-43518","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-43518"}],"summary":"Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer"}