{"action":"Upgrade npm to 8.4.1~ds-1 or later.","affected":[{"fixed":"8.4.1~ds-1","introduced":"0"}],"component":"npm","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["8.4.1~ds-1"],"id":"tcs_01M5NG1Q389RVPDPY7AXCY8EV2","modified_at":"2026-10-23T18:03:39.005190287Z","published_at":"2021-11-13T18:15:07.537Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-43616","https://security-tracker.debian.org/tracker/CVE-2021-43616"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-43616#Debian:13/npm","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-43616"}],"summary":"The npm ci command in npm 7.x and 8.x through 8.1.3 proceeds with an installation even if dependency information in package-lock.json differs from package.json. This behavior is inconsistent with the"}