{"action":"Upgrade node-yarnpkg to 1.22.19+~cs24.27.18-1 or later.","affected":[{"fixed":"1.22.19+~cs24.27.18-1","introduced":"0"}],"component":"node-yarnpkg","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.22.19+~cs24.27.18-1"],"id":"tcs_01M5NG1Z2DS3S5DRH86MSY0JXZ","modified_at":"2026-10-23T18:04:50.227059370Z","published_at":"2024-02-04T20:15:45.657Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-4435","https://security-tracker.debian.org/tracker/CVE-2021-4435"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-4435","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-4435"}],"summary":"An untrusted search path vulnerability was found in Yarn. When a victim runs certain Yarn commands in a directory with attacker-controlled content, malicious commands could be executed in unexpected w"}