{"action":"Upgrade squid to 5.6-1 or later.","affected":[{"fixed":"5.6-1","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.6-1"],"id":"tcs_01M5NG3D9NA5YFXYJTCYDSF8DC","modified_at":"2026-10-23T18:04:17.472976319Z","published_at":"2022-07-17T22:15:08.737Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2021-46784","https://security-tracker.debian.org/tracker/CVE-2021-46784"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2021-46784#Debian:14/squid","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2021-46784"}],"summary":"In Squid 3.x through 3.5.28, 4.x through 4.17, and 5.x before 5.6, due to improper buffer management, a Denial of Service can occur when processing long Gopher server responses."}