{"action":"Upgrade vim to 2:8.2.4659-1 or later.","affected":[{"fixed":"2:8.2.4659-1","introduced":"0"}],"component":"vim","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2:8.2.4659-1"],"id":"tcs_01M5NGBC0RJWY81WBAB99FN2YX","modified_at":"2026-10-15T08:00:35.838577707Z","published_at":"2022-03-14T21:15:07.887Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-0943","https://security-tracker.debian.org/tracker/CVE-2022-0943"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-0943#Debian:13/vim","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-0943"}],"summary":"Heap-based Buffer Overflow occurs in vim in GitHub repository vim/vim prior to 8.2.4563."}