{"action":"Upgrade protobuf to 3.21.9-3 or later.","affected":[{"fixed":"3.21.9-3","introduced":"0"}],"component":"protobuf","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.21.9-3"],"id":"tcs_01M5NGDQ1BVEW3R49STPCSPTNN","modified_at":"2026-10-15T08:01:23.754895704Z","published_at":"2022-09-22T15:15:09.203Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-1941","https://security-tracker.debian.org/tracker/CVE-2022-1941"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-1941","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-1941"}],"summary":"A parsing vulnerability for the MessageSet type in the ProtocolBuffers versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 3.21.5 for protobuf-cpp, and versions prior to and inc"}