{"action":"Upgrade fish to 3.4.0+ds-1 or later.","affected":[{"fixed":"3.4.0+ds-1","introduced":"0"}],"component":"fish","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.4.0+ds-1"],"id":"tcs_01M5NGDV6JTGMSD9APGEZR83YW","modified_at":"2026-10-15T08:02:12.425488980Z","published_at":"2022-03-14T19:15:11.997Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-20001","https://security-tracker.debian.org/tracker/CVE-2022-20001"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-20001#Debian:13/fish","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-20001"}],"summary":"fish is a command line shell. fish version 3.1.0 through version 3.3.1 is vulnerable to arbitrary code execution. git repositories can contain per-repository configuration that change the behavior of"}