{"action":"Upgrade node-css-what to 5.0.1-1 or later.","affected":[{"fixed":"5.0.1-1","introduced":"0"}],"component":"node-css-what","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.0.1-1"],"id":"tcs_01M5NGEEFBDVVFPFYCJEFN4XDX","modified_at":"2026-10-15T08:00:44.731492718Z","published_at":"2022-09-30T05:15:08.713Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-21222","https://security-tracker.debian.org/tracker/CVE-2022-21222"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-21222#Debian:13/node-css-what","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-21222"}],"summary":"The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation o"}