{"action":"Upgrade node-marked to 4.0.12+ds+~4.0.1-1 or later.","affected":[{"fixed":"4.0.12+ds+~4.0.1-1","introduced":"0"}],"component":"node-marked","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.0.12+ds+~4.0.1-1"],"id":"tcs_01M5NGEVT2RYK6A2JX5S61SXP0","modified_at":"2026-10-15T08:01:01.761188982Z","published_at":"2022-01-14T17:15:13.270Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-21681","https://security-tracker.debian.org/tracker/CVE-2022-21681"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-21681","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-21681"}],"summary":"Marked is a markdown parser and compiler. Prior to version 4.0.10, the regular expression `inline.reflinkSearch` may cause catastrophic backtracking against some strings and lead to a denial of servic"}