{"action":"Upgrade joblib to 1.2.0-1 or later.","affected":[{"fixed":"1.2.0-1","introduced":"0"}],"component":"joblib","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.2.0-1"],"id":"tcs_01M5NGF23VP9W42QARP01S9FT6","modified_at":"2026-10-15T08:01:33.864957677Z","published_at":"2022-09-26T05:15:10.427Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-21797","https://security-tracker.debian.org/tracker/CVE-2022-21797"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-21797#Debian:14/joblib","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-21797"}],"summary":"The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement."}