{"action":"Upgrade rails to 2:6.1.6.1+dfsg-1 or later.","affected":[{"fixed":"2:6.1.6.1+dfsg-1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2:6.1.6.1+dfsg-1"],"id":"tcs_01M5NGF98FNYZFNQX9B3PRKV9X","modified_at":"2026-10-15T08:01:40.448111798Z","published_at":"2022-05-26T17:15:09.133Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-22577","https://security-tracker.debian.org/tracker/CVE-2022-22577"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-22577","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-22577"}],"summary":"An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses."}