{"action":"Upgrade rails to 2:6.1.6.1+dfsg-1 or later.","affected":[{"fixed":"2:6.1.6.1+dfsg-1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2:6.1.6.1+dfsg-1"],"id":"tcs_01M5NGF9BRVY471Z69RY6NBGAH","modified_at":"2026-11-03T08:03:49.819523332Z","published_at":"2022-05-26T17:15:09.133Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-22577","https://security-tracker.debian.org/tracker/CVE-2022-22577"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-22577#Debian:13/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-22577"}],"summary":"An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses."}