{"action":"Upgrade pillow to 9.0.0-1 or later.","affected":[{"fixed":"9.0.0-1","introduced":"0"}],"component":"pillow","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["9.0.0-1"],"id":"tcs_01M5NGFZFYMVCJ6VXQ34VZW8CQ","modified_at":"2026-10-15T08:01:41.276487285Z","published_at":"2022-01-10T14:12:55.160Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-22817","https://security-tracker.debian.org/tracker/CVE-2022-22817"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-22817","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-22817"}],"summary":"PIL.ImageMath.eval in Pillow before 9.0.0 allows evaluation of arbitrary expressions, such as ones that use the Python exec method. A lambda expression could also be used."}